• ARCore (Unity) Camera Permissions Dialog Never Shown When using ARCore in Unity, any apk that I publish doesn't ask for Camera Permissions.

    I've noticed that in the Android Studio AR Demo code that they were using a CameraPermissionsHelper class, and are calling the requestCameraPermissions() in the onResume(). This is easy for a project created in Android Studio, but doesn't help in Unity.

    The Unity ARCore SDK does contain a AndroidPermissionsManager, but, I'm not quite sure how to implement in Unity correctly.

    Has anyone solved or come...

    ARCore (Unity) Camera Permissions Dialog Never Shown
  • 3D Body/Avatar for Virtual Reality on Unity – PC platform Hey,

    Do you guys know how I can incorporate a 3d body model to represent myself in VR? I am building a VR multiplayer game and want each player to see each other like VR Chat on steam.

    What do you recommend? I found a package on Unity store but unfortunately it's only for mobile vr. I have a few ideas like attaching a head as a child to the parent of the VR camera. The body as a separate object but maybe attached to the head could have updated animations based on the position of the...

    3D Body/Avatar for Virtual Reality on Unity - PC platform
  • Best performance for forest scenes in VR I was hoping of adding a larger forest multiplayer map to our game. I did some tests, downloaded the free speedtree from untity asset store, a basic terrain, a mixed mode directional light and painted a few trees. Got maybe 45 fps because of too many s...
  • VRTK: how to wait for a headset to be plugged in Hi,

    I'm using VRTK and everything seems to work fine as long as a headset is plugged before I launch the application, but I would like to cover the case where it is not, and would like to display a message while the device is not connected.

    Fo the moment, I see no event when a headset is plugged in, and even after a while, I see a black screen and that's all.

    Any idea where I should look getting events?

  • Depth/world position reprojection Hello everyone.
    I'm building a raymarching shader. It's working well but I'm still looking to optimise its VR usage. I have read about calculating the depth once for a middle eye, reprojecting it to both eyes, and doing the rest of the shading afterwards. I thought I could also use world position since its also computed by the raymarcher.
    My context is already set up : a first pass render the worldPos to a square render texture. The second shader pass should reproject world pos and compute...

    Depth/world position reprojection
  • How could we access depth texture from device camera? For doing AR I would like to access depth texture to run a computer vision, calculate depth of the things in scene. Which ARCore was not really utilize it

    Are there any API or anyway I could access depth texture? It should be possible from android and iOS with stereo camera yet I can't find any available information about it in unity
  • Setting the ImageTarget name as a variable? Hi, I have a slight problem that is driving me mad. What I want to do is to get the name of the currently tracked ImageTarget set to a variable so I can call it from a function. The scenario is like this: I have a set of different products that are r...
  • Two Handed Weapons Hi, so I'm trying to create a sniper rifle in virtual reality, and ideally I would like it to be so that one hand would hold on to the trigger area of the rifle, and the other hand would hold the barrel of the rifle, like how you would hold a sniper rifle in real life. Using VRTK however, I can't seem to find a way to hold on object with both hands at the same time. Does anyone know how to accomplish this, with or without VRTK? Thanks.
  • “App not installed’ error Hi all!

    I am an absolute beginner so please forgive the very simple level of my knowledge.

    I followed a simple tutorial on YouTube showing how to create and build some basic AR for a phone App.
    I successfully built a test Android App which uses a Vuforia trigger to show a simple 3D object which I had textured with some basic PNG images. It worked great - first time!

    Then I created more parts to my model and textured them, built the App again but this one will not install. I just keep...

    "App not installed' error
  • ARKit Detection Progress I've seen some applications in iOS that have a tracking progress bar, basically telling you how much you left you have to move your phone around before you can place object in the scene. Is it possible to do that in ARKit?
  • Lightweight Render Pipeline + Post Processing w/SteamVR Is anyone able to use the Post Process Profile with the new lightweight render pipeline for their SteamVR project? When playing the scene I'm able to see the effects of the post processing in the Scene window of the editor but it isn't applied to the game view or the view in HMD. I'm currently using version 2018.1.3f1. Any help is appreciated.
  • Ideas on Motion (Walking) for HoloLens AR Apps How have you guys implemented navigating a virtual scene in AR (HoloLens) ? In PC apps, you can use the keyboard controls to move around a character (first person). I want to control a first person character in HoloLens and need some ideas on how to im...
  • Pink Screen on Scene loading I am new to unity and having a frustrating issue I will do my best to explain! I have created a little demo piece based on Windows Mixed reality headsets, the piece is made up of 3 scenes. Scene 1 is essentially a scene selection screen, there is a ca...
  • [ARCore] v1.4 | Trying HelloAR project, build succeed but nothing shows on the phone. Hello, i'm new to Unity and ARCore and i am trying to lauch the ARCore exemple project, but nothing is showing on my phone.
    I'm using the Unity 2018.2.2f1 and ARcore v1.4, but i had the exact same problem when i used the previous version (2018.2.1f1 and 1.3).
    I run Unity on Windows 10.
    Here is what i did :
    - I create a new project named "AR"
    - I add the " arcore-unity-sdk-v1.4.0 " package
    Assets > Import Package > Custom Package ...

    v1.4 | Trying HelloAR project, build succeed but nothing shows on the phone.
  • Error using TargetRpc on HoloLens Hello, I am getting a TypeAccessViolation Error on the host whenever a client fires a missile. I am using a TargetRpc over Unet with the HoloLens. However, I am doing it exactly as the example in the documentation found here. Is there a reason for thi...