• Rendertexture with stereo rendering modes (it doesn’t work) I would like to be able to use RenderTextures in VR so that I can perform postprocessing effects. At this exact moment, I am attempting an effect where a shader is used to paint a surface with , like a "portal" from Portal, or like a stencil buffer (I am not using a stencil buffer because I may add additional effects later). It does not work. I am getting different failure modes depending on which "Stereo Rendering Mode" I use.

    I have a minimal example project in this git repo...

    Rendertexture with stereo rendering modes (it doesn't work)
  • Vuforia 7.2 camera settings and arcore I've updated my project to Vuforia 7.2 and imported the ARCore plugin. The Ground Plane is now working amazing on my Samsung S7 Edge. However, I'm unable to focus the camera properly.

    Before, I'd have it so if you tapped on the screen, it would focus the cam by using this code:


    But now that doesn't do anything. I saw in the Known Issues section - that "ARCore versions 1.0-1.2 do not support continuous...

    Vuforia 7.2 camera settings and arcore
  • possible to live stream Gear 360 in Unity? Greetings, Is it possible to live stream Gear 360 view in Unity, on a program running in Windows? I think Gear 360 only connects to Samsung phones via bluetooth. but it has the option to broadcast to yutube, fb, or Samsung VR. Is it possible to get th...
  • Want both Vive and Oculus support in one app Hey all...

    I'm trying to find the path of least resistance in creating VR apps that support both Vive and Oculus. My needs are not all that much, just head tracking, basic controller input and teleportation.

    I tried VRTK and got it up and working with Vive. However, when I hooked up my Oculus, I was not getting any controller tracking at all in either my app or their sample apps.

    So, I'm looking for alternatives. I understand that SteamVR can support both Oculus and Vive. However, I...

    Want both Vive and Oculus support in one app
  • UnityEngine.XR.XRDevice.GetNativePtr();

    How do I use this?

    My primary desire is to fire haptic events on Vive, Oculus and windows MR controllers without needing to import the SDK's for these headsets.
  • Image Tracker issues in ARCore 1.3.0 I downloaded ARCore SDK to 1.3.0 and the latest update from the Play Store.
    In previews version the Image Tracker worked fine.
    But in the current version even if it recognize the image, the next frame there's already large drift, even if the phone stays in place, and after a few frames there's a need to locate the marker again...

    Did it happen to more people?

    I'm using Samsung Galaxy S7
  • Question about vr controller mesh model. I'm collecting the mesh models for vr controller in order to make different controller type support.

    I noticed that the some meshes are included in those vr sdks, but some aren't.

    And I also noticed that in SteamVR, those missing vr controller mesh models are bundled.

    My question is: is it "safe" to use the mesh in steam vr? I mean, can I use it for proprietary usage in Unity Product as a controller model?
  • ARkit for android I have been doing research into whether the arkit sdk can be used to build to android in unity? I can't seem to find a conlcusive answer yet.
    I am curious to find out because googles arcore sdk can be built to ios using cloud anchors. I was wondering if the arkit plugin could be used on android devices.
  • Vuforia 7.2.20 and Android submission : ARCore isn’t in AndroidMa Hey, On Unity 2018.2.6 I updated Vuforia to 7.2.20 without problem and made an apk which works fine. Then I uploaded it on Google Play, and got an error saying that: The minimum version code of the ARCore dependency
  • Vuforia: Camera shaking Hi guys,

    I'm new in Vuforia and I'm working on a project for my company and I'm testing Unity 5 with Vuforia to decide the technology to use.

    I have an issue with image target recognition. I can see that my 3d models are shaking.

    When I select the AR Camera it is moving and rotating.. just a little but it is noticeable

    I have tried:

    - An Image Target of width 11cm and height 11cm.

    - An Image Target of width 4cm and height 2 cm.

    - A VuMark with width of 9cm and height 5cm.

    - A...

    Vuforia: Camera shaking
  • ImageTargets work in Play mode, but not in build (iOS) I have a scene with some database-loaded image targets. When any image target is detected, a green capsule model appears. This works in Unity Play mode using my webcam, but once I have built to Xcode and then to my iPad device, the model does not appear. I've tried this with all my image targets, using the webcam, all of them will cause the model to appear. But on my iPad, none of the images cause the model to appear.. what are the possible reasons for this? I have no idea how to fix it.
  • “Best Practice” Project Settings for Daydream? Generally speaking, when targeting Daydream VR and Google Pixel (and subsequent Daydream-certified devices): * Should we enable vsync or not? Is this setting ignored at runtime anyway? * Does using 32-bit display buffer have any special significance o...
  • Shared Spheres Multiplayer Project unable to join host Just tried out the Shared Spheres demo - built using Xcode beta 10 and using Unity 2018 as well as Ios Ipad Devices running public beta IOS 12. We are unable to get a broadcast with captainsmess received between two ipads in the same network - notably...
  • Unable to build IOS Arcore Multiplayer Light Board demo Hi Everyone

    I have been trying to build and run the 'Light Boards' Multiplayer demo for IOS using ARCore through the git repo provided by google. However, there seems to be a cocoapods related error during the build process where some dependencies aren't added. (see error in code box below)

    Also we think this error may be stopping the build from running due to the project build process not including dependancies and generating a .xcworkspace file that needs to be opened instead of a...

    Unable to build IOS Arcore Multiplayer Light Board demo
  • OculusGo Assertion failed Hi!
    I've been trying to test OculusGo with a sample scene, I could build it a couple of times at the beggining (after adapting the test project scene to the oculus) but then this error started popping. I was implementing this ( controller pointer and was working until now.
    Any ideas?
    Build versión: Android.
    Code (CSharp):
    1. Assertion failed: Assertion failed on expression:...
    OculusGo Assertion failed