Forums

  • Tilt Brush – Multiple audio reactive sketches, each with its own audio source, in Unity? The audio reactive export pipeline to Unity is fantastic but I would like each Tilt Brush object to have and react to its own audio source. Digging in, I found VisualizerAudioInput.cs with this invitation in comments: //Get audio data from Unity (Hint...
  • Error: Unable to find libAudioPluginOculusSpatializer Hi everyone, I'm building an OculusGo app where 2 or more people can voice chat between them.
    I tested Photon Voice 2 from the asset store and the demo from them worked fine on some Android devices. Now I built for OculusGo and when I check the logcat it says:

    04-29 15:26:07.143 5650 5665 E Unity : Unable to find libAudioPluginOculusSpatializer

    I'm using Unity 2019.1 and I checked the Oculus Integration that I downloaded from the asset store and there is a file under...

    Error: Unable to find libAudioPluginOculusSpatializer
  • Model Target At Fixed Position Hello, I am trying to keep the augmentation(3D Car Model) at the exact detected position after the model target is detected. The augmentation should not move or rotate, even if I move the device(iPad camera) somewhere else. In unity, I have tried ...
  • ARCore SDK Preview 2 is encountered a problem connecting. please start the app again. hi, my names Nando and im test the new SDK Preview 2 from ARCore SDK at github. but the problem i got after i build and install it on devices the problem is "arcore encountered a problem connecting. please start the app again." somebody have ...
  • Motion Controller Input Changes Hello, I have updated my project to Unity 2019.1 and I have a strange behavior on motion controller input, in detail Touchpad Press works as "touch" instead of "press", in the prior version of Unity like 2018.3 works properly. The menu button stop working for each controller in Unity 2019.1 but works on Unity 2018.3, I don't know why, Thank you, Best regards…

    View attachment 412102
    View attachment 412105
    View attachment 412108
  • No PostFX on Android using LWRP Hi,

    I've the problem that there are no PostFX. on my android build.
    Maybe something else is wrong...

    This is the PC Editor version:
    View attachment 411736

    And this is a screenshot from my Google Pixel 3
    View attachment 411733

    Here are my settings:
    View attachment 411757

    View attachment 411760


    I'm using Unity 2019.1.0f2
    View attachment 411763

    I hope some one can help me...
  • Cannot for the life of me get mobile vr to work Hey up, ive managed to build a simple vr game to my HTC m8 and it opens fine but no matter what I try I cannot get the camera to turn? Im using the latest google vr sdk and tried every combination of the prefabs Any help?
  • How to reduce Shader Variant Compiletime for VR with LWRP Hi guys,
    how to reduce Shader Variant Compiletime for VR with LWRP?

    With the default LWRP VR Scene building Shader Variants takes over 20000 variants for posteffects.
    I've a buildtime for this of around 30min to 45min. That isn't practicable for testing on android.

    How can I reduce those?

    I heard that this is possible by stripping them, but the process for that isn't well documented. Especially the possible keywords for that.
  • Camera position depending on Gameobject in prev. scene | UnassignedReferenceException Hi, I have 2 scenes: AR and VR. In the AR scene there are 2 teleporter gameobjects that start the transition to VR. Depending on which teleporter I have selected, I would like to set the camera in VR to a specific position. Code (CSharp): public ...
  • switch plattform to android I am a bloody unity beginner: I try to connect my unity project to the app unity remote to watch it through vr. It is not possible to switch it from built settings/switch plattform . It tells me "no android reloaded." what does that mean? Hav...
  • Particle System not working on Oculus Go Hello, I'm using Unity 2019.1.0f1 with LWRP 5.7.2 to do an app to Oculus GO.

    It worked very fine but when I put a particle system the app became to crash.
    Then I've done some test and I found that, when I use the LWRP on Oculus GO is when it begin to fail.
    When I see the first frame that will render the particle, the app stop rendering any other frame.
    I tryied on a simple Android and Gear VR and it works with the same APK that doesn't work in Oculus GO.

    Do anyone knows what's happening?...

    Particle System not working on Oculus Go
  • Easy AR loading time and marker issue. Hello Everyone, Facing one strange problem. Highly appreciable if someone can help me. I made one Android AR app using Easy AR having approximately 100+ markers. When I try to open the app using Wi-Fi/Mobile Data Its working fine almost in all device...
  • Teleportation during scene transition not working in Steam VR 2.2 Hello Everyone, When using steam vr 2.2 (in Unity v2018.3.13f1 and Unity v 2019.1.0f2) with the HTC Vive Pro, there is an issue where the teleportation area no longer works after a scene transition. This is sometimes characterized by an increased GPU ...
  • Top VR SDK reverts to None after level change If I manually drag the OpenVR SDK to the top of the SKD list, it all works fine until I change the scene. In the newly opened scene, "None" is back on top. I tried enabling OpenVR from code in each scene, but I'm getting the "Assertion failed: Assertion failed on expression: 'IsMatrixValid(matrix)'" error. Below is the coroutine I'm using. How can I fix it?

    IEnumerator SwitchToVR()
    {
    string desiredDevice = "OpenVR";
    if (UnityEngine.XR.XRSettings.loadedDeviceName ==...

    Top VR SDK reverts to None after level change
  • How to replace element in MeshRenderer.sharedMaterials We are using a object from the asset store that makes usage's of a mesh renderer with 32 materials in it. We need to implement functionality that makes it possible to replace 1 single material in the list, and keep the rest.

    I have tried several things, but I keep struggeling with the materials list, that is why I decided to ask you guys for help.

    Code (CSharp):
    1. public Material TestMaterial;
    2.  
    3. void Update()
    4. {
    5.        for (int i = 0; i < meshRenderer.sharedMaterials.Length; i++)
    6.        {...
    How to replace element in MeshRenderer.sharedMaterials