Forums

  • Vive Focus 6DOF Hi Guys,

    I have the Vive Focus, and have System Update 2.0 installed (ROM 1.33.1400.5). I'm using the samples from Vive for Unity, and they're all working okay. One issue though. I can't get 6DOF working. I don't know why. Not either in the app or on the device itself. Can anyone help?
  • Tracked objects disappear when loading new scene Hi, I'm developing an ARCore game and I have multiple scenes that have to be in AR. I have tried to put a DontDestroyOnLoad on the Controller, AR Device, on the planes and the Andy prefab.

    When loading a new scene, the camera feed works fine, but the objects that have to be tracked disappeared. Has anyone experienced the same problem? Any solution?
  • Set Unity World Origin at anchor Hi, I have a set of different scenes, and for the game to work as intended, I would need to set the World Origin (0,0,0) on an anchor placed by the player in the first scene. Is it possible? Or instead of doing that, should I make all the objects of a...
  • Inconsistent Behaviour with Motion Controllers and Camera I am certain others have encountered similar issues. First the unpredictable behaviour of the camera changing elevation has me baffled. Ive noticed the same behaviour even inside the Cliffhouse in Windows 10 Mixed Reality Portal. Somethings your viewin...
  • [Hololens] Changing color of primitive I am trying to change the color of a primitive cube, created

    Code (CSharp):
    1. arrow = GameObject.CreatePrimitive(PrimitiveType.Cube);
    I then change it's color as such;
    Code (CSharp):
    1. Renderer r = arrowGetComponent<Renderer>();
    2. r.material.color = new Color(0,1,0,1);
    This works fine in the unity editor however when I deploy the app to my hololens the color remains the same.
  • Anyway to stop Vuforia asking for camera permission at startup? (Android) First off, this is only an issue when splitting the APK into a .obb file. Single APK works fine.

    I'm using this library here which works great: https://github.com/Over17/UnityAndroidPermissions

    Vuforia version is: 7.0.50
    Unity version is: 2017.4.4f1

    Can't upgrade to 2018.1.

    I've tried everything, from steps described in these places:
    https://forum.unity.com/threads/use...n-individual-scene-not-entire-project.498489/...

    Anyway to stop Vuforia asking for camera permission at startup? (Android)
  • Windows MR & VRTK – Warning 0xdef00520 – Invalid qualifier: DLL-RESOURCES Hi All,

    I'm currently attempting to build (which will be deployed to the Windows Store) a project using the following:

    Visual Studio 2017
    Unity 2018.1.3f1
    VRTK 3.3.0a
    VRTK Windows MR Extension

    I'm able to build successfully in Unity and Visual Studio 2017. I do get the below warning:

    0xdef00520 - Invalid qualifier: DLL-RESOURCES

    It...

    Windows MR & VRTK - Warning 0xdef00520 - Invalid qualifier: DLL-RESOURCES
  • How to Change Grab/Interact Button on SteamVR? Using SteamVR for Oculus Rift, The standard button for grabbing an object is the frontal (or index) trigger, but since I am grabbing a Fire Extinguisher that I wish to eventually use the index trigger to "shoot" it to put out some fire. So I'd use the lateral (Hand) button (Grip) to keep holding it, and the trigger to Spray it instead.

    I already got the line to use the button in a general use (Equivalent to Input.GetKey(KeyCode.key)):

    Code (CSharp):
    1. if...
    How to Change Grab/Interact Button on SteamVR?
  • Motion Controllers (Vive or Oculus) without plug-ins (SteamVR or Oculus Tools) Is it possible to make use of the motion controllers (Vive) or the Oculus Touch controllers with native Unity 5.5 - i.e. without the SteamVR asset nor the Oculus Tools?

    I noticed that the Vive HMD works fine without SteamVR, but I'm not sure how and where to add controller support, as they don't "simply work".

    Any pointers would be greatly appreciated.
  • Unity SDK with tobii 4C Hi guys, I would like to ask if someone can help me, I am trying to understand how can I implement the eye movement into Unity speaking about the scripting, I have downloaded the unity SDK but still find myself lost. I am looking to do a spinning cube...
  • Update Vuforia Image Database Hey there,
    maybe it's a general question concerning the Unity Editor, but I want to update the Vuforia Image Database in Unity and replace an image target with a complete new one.

    How do I update a database without messing everything up in the Asset-Folder?
  • HoloLens Depth Buffer errors Hey guys,

    Getting an error on the HoloLens
    "Failed to commit the depth buffer via CommitDirect3D11DepthBuffer. Error Code '0x80070057'"
    (Filename: C:\buildslave\unity\build\Runtime/VR/HoloLens/VRDeviceHoloLens.cpp Line: 560)

    Only happens occasionally (once out of ten launches)
    Anyone have a clue what it's related to?

    HoloLens OS: 10.0.17133.1009
    Win SDK 10.0.17125.0
    Unity 2017.4.0f1

    Build Settings:
    D3D
    .NET Scripting Backend using 4.x
    Enabled Shared Depth buffer in Windows MR SDK
  • Hi guys, i have a question about The Valley VR Demo Hey dudes, the VR demo I've been working on finally passed the Oculus submission process and is available to download..
    Thanks to everyone who gave me advice on the forum, and if you've got the time please check it out!
  • Multiplayer AR Synchronize worldspace Hi, for studies we invent a jenga-AR-Multiplayer. Singleplayer is allready working fine and a "windows-simulation" with multiplayer also works. But when bringing it together i have a problem. Here is the szenario: Player-H (host): starts g...
  • Shader.SetFloat not work Hi,
    I'm trying to set a uniform variable for one shader used for multiple materials.
    In unity editor the result is what I want.
    I set Shader.SetFloat("variable", value) and my result is acchieved.
    Inside the hololens nothing happen.
    Do you have any solutions or work around?
    Is this a bug?

    Thanks