Forums

  • Xiaomi Mi A1 Hi!
    I'm using Unity 2018.1.0f and Vuforia 7.1.34. If I make a build and run it on Xiaomi Mi A1, the fps of the camera is really low. Even if I build a sample project or a completely empty project the FPS is very low, the video plays back normally, though.
  • Vrtk controller objects are destroyed on run. Hello i experienced something really strange i am driving myself crazy trying to fix it. Suddenly from what seem to be nowhere the ability to access the vive controllers was lost, they dissiperar on runtime, not just the mesh but the whole GameObject. I tried searching online and even uninstalled unity to latest version, well vrtk don't work on the latest. So now i am back to unity 5.6.2, and the problem is still there. It is not just my apps, if i open vrtk example scenes the same problem...

    Vrtk controller objects are destroyed on run.
  • Camera not Changing Position I am trying to change the camera position when the Motion controller trigger button is pressed. Only the text updates which confirms that the trigger press returns true. However the call to explictly change the camera position doesnt work. Code (CS...
  • Why are WorldAnchors not saving scale? So world anchors are saving position and rotation. Is there any particular reason why they dont save scale? Would be awesome if they save the whole transform
  • UnityWebRequest not working when deployed to the HoloLens Hey,

    I am quite new to Unity and the HoloLens, so excuse me if my question seems simple, but I've been trying to deploy an app to the HoloLens which includes calls to a WebAPI and the following issue has happened:

    Formerly, I used the HTTPWebRequest class for the requests to the API, but since it wouldn't allow me to build the solution, I ended up changing all of my HTTPWebRequest classes to UnityWebRequests instead.

    Now, basically, whenever I play the editor inside Unity it works...

    UnityWebRequest not working when deployed to the HoloLens
  • How to switch camera Back-to-Front option ? Hi,Every one.I have some question.

    Because I want to switch from the back to the front camera at running iOS device.And then search review Unity document.I think I can to use WebCamTexture switch device camera, get new Camere pixels info.and reset YUV texture at UnityARVideo.

    But It is to my mind,Maybe have some option can use in ARKit API reference? I'd like to use it.

    Thanks!
  • Unity3d – how to limitation play exe file? hi everyone. i need some help.
    i'm programming unity3D(using Mixed Reality). and i need limit my built program(exe file).

    1. A computer and another computers.
    2. and A computer is available play exe file, but another computers are not available play exe file.

    sorry about my english speaking. just i need limitation another computers are not available play my built exe file.
    have a nice day :)
  • How to know if Windows MR device is used in SteamVR Is there any way to tell if the connected OpenVR/SteamVR device is a Windows MR headset? It's easy to tell from the device name the difference between a Vive and Oculus but with all the different Windows MR devices is there a way to tell that it's WMR in general?
  • (Vive) Single Pass Rendering not working with assetbundles Hi,

    Was wondering if anyone else had this problem. When I try to use single pass rendering I can see it working normally on my initial scene of my project, but once I load a scene that comes from a downloaded assetbundle, the single pass rendering then stops working. You can see the different eyes do not line up properly.

    Any ideas? I'm stuck using multi pass as it is now.
  • WACK submission to store Failing due to .dll errors , any ideas? Hello Everyone I am submitting an app to the Microsoft store and Am now encountering an issue with some of the compiled libraries included in my project. We've built our app in the unity Game engine and are using the Holotoolkit in our project as well . Does anyone have any Ideas on how to manage/ fix this ? The following are the errors displayed on our WACK submission.


     Error Found: The supported APIs test detected the following errors:
    API ExecuteAssembly in uwphost.dll is...


    WACK submission to store Failing due to .dll errors , any ideas?
  • Hololens 360 Video Hey everyone, I have created a project in which a 360 video starts immediately. I made it a skybox panoramic instead of going the sphere-texture route. The video then leads into a quiz. I have gotten everything working correctly but when I deployed to...
  • Key resources for HoloLens development There are some great resources for developing for HoloLens with Unity available on the Windows Developer Center. I recommend exploring the documentation as a whole but here are must-see topics: Learn how to install the tools needed to develop hologra...
  • How do you detect if you have a Vive or Vive Pro in Unity. Hi

    Previously I've been using:

    if (((UnityEngine.XR.XRDevice.model).LastIndexOf('Vive')) == -1) {
    // It's a Mixed reality headset
    } else {
    // It's a Vive headset
    }

    I've just had someone who has a Vive Pro get in touch and say that it wasn't detecting as a Vive but a MR headset. What should I do to detect a Vive pro as well?

    Any help with this would be very welcome.

    All the best

    Phil
  • Hololens and Socket.IO I can get Socket.IO to work well in Unity. I can also get Unity to publish directly to the Hololens. The problem now, is that once I import the MixedRealityToolkit into Unity alongside of a few DLL files for Socket.IO (NewtonsoftJson.dll, SocketIoClientDotNet.dll, WebSocket4Net.dll) I run into a bunch of errors. It's telling me that I have error CS0433: The imported type 'System.Action<T1,T2>' is defined multiple times (on scripts from the Holotoolkit asset folder). I'm also getting...

    Hololens and Socket.IO
  • How to get the motion controllers to work in Unity? I'm trying to get a Samsung Mixed Reality HMD working in Unity with the motion controllers.

    I've downloaded the MRTP4 build, installed the Dev.2017.2.1 unity packages into my project, and ran one of the examples scenes after the Cliff House portal is running. When I Play the scene, it doesn't send any data to the HMD. When I try to enable "Target Occluded Devices" under the "Mixed Reality Toolkit > Apply Mixed Reality Project Settings" I get an error: "Switching to Universal Windows...

    How to get the motion controllers to work in Unity?