• Just the basics… on a Mac At home I have a decent PC running Windows. But I also have a (brand new) macbook pro. I know I can't expect amazingly lovely beautiful fast smooth VR using my HTC Vive on my MBP. But is there a way, without buying an EGPU, to just get the basics? I mean I currently want to build a plain room and put a button in it that I can push with the vive controller. If I could do that, and run it at say 60fps - I would be happy. When I make it (laugh) production level I can run it from the PC but from...

    Just the basics... on a Mac
  • Markerless AR fix object at the position hello all,

    From the link provided below, the character moves when the phone is moved along with it. Is it possible to fix the character's position in the scene? How do I achieve it?

  • Standalone build rendering hang Hey All, I have a standalone build that hangs in the same spot (loading a certain scene) 20%-30% of the time. I have added tons of debugs through out the code and I think the issue has something to do with rendering (last debug message in the output i...
  • Problems with using VS2019 only Hi, (this is a repost of an unanswered question with some changes from the General discussion)
    Has anyone had this problem? I have updated to latest LTS 2017.4.20f2 but it isn't able to build the HoloLens UWP project even though I've set the path to the Visual Studio's devenv.exe in the Edit>Prefrerences>External Tools manually and now in the drop-down it recognizes and says "VS2019 experimental"...
    I realize LTS is an old version of Unity and that VS2019 now comes with Unity 2018,...

    Problems with using VS2019 only
  • How in Unity of action of the button to attach to AR-objects (ImageTarget)? There are several ImageTargets, and there are three buttons in the interface, when you click, the sound plays (voicing in three languages). How can I attach an action to ImageTarget?
  • unity and vuforia Hello, i need someone to help me and guide me. i am thinking to create coloring book, with Region Capture Vuforia and unity. where i can save my experiences, in order to give the users to download the app that i created with unity and vuforia, i need t...
  • Unity3d 2018.2.4f1 automatically switching VR SDK to None in playerSettings at random Im having major issues all of a sudden where unity is automatically re ordering my SDK priority in player settings. I have it set to Oculus then openVR then none and all of a sudden after building in VR for months, its decided to randomly change the SD...
  • Vuforia 8.0.10 / Unity 2018.3.5f1 – Model Target can’t select my database I have generated a model target using the android app, uploaded it to a target library, and downloaded it as a unity package then installed it.

    I have a dev license which I have configured. My database shows up in Vuforia engine configuration.

    I have successfully imported image targets and had no issue.

    When I add a ModelTarget to the scene I am told I have no databases, and asked if I want to import the a sample one.

    When I inspect the files of the sample database, the underlying data...

    Vuforia 8.0.10 / Unity 2018.3.5f1 - Model Target can't select my database
  • Why does RenderTexture never work on android build (Oculus Go) Hi, I've had this problem for over two weeks now. Tested on both Unity 2018.3.1 and 2018.3.2.

    I've created a CustomRenderTexture asset, I've copied the simple shader from the documentation, it's supposed to just draw a color to the texture. I apply this CustomRenderTexture material to a Quad in scene. This works on desktop in play-mode and in editor. But it never works on device.

    I've tried writing...

    Why does RenderTexture never work on android build (Oculus Go)
  • How to create an Unity3d Hololens build for publish on Microsoft store Hi,

    I just need to know the proper steps to create and submit an Unity3d Hololens app build on Microsoft store.
    I have created and publish the app on store as per Unity3d mixed realty Microsoft guide line but that has rejected from store.I am facing this problem.

    Error is ''The app does not install on currently selected device families''.

    - does not install on - Hololens

    Please help me.

  • How to detect if Image Target is not “well” tracked Hello,
    I have a quite hard to track cylindrical image. When I'm near enough to the image everything is fine most of times, but sometimes, depending on lighting conditions, the tracking is not very "stable": I mean that my Gameobject that overlap the image move and rotate instead to stay attached to the image.

    So, is it possible to detect when the tracking is poor (NOT when the target is lost!) to, maybe, hide the Gameobject and show a message, for example "WARNING: TRACKING IS NOT WORKING...

    How to detect if Image Target is not "well" tracked
  • Does ARSessionTrackingChangedEvent not fire when using Remote? I could have sworn ARSessionTrackingChangedEvent fired even when using Remote but it's not working. Works fine on device, but it sure would be nice if it worked on Remote. Can anyone confirm one way or the other please?
  • How to swap oculus hand models with my own? (not a noob) I'm not a noob/newbie whatever i just need a rough explanation of the things i need to do in order to get this done. i noticed that people mention the fact that the hand models are created at run time but what i want to know is how i should go about swapping out the OVR local player hands with my own models and do i need to create my own custom hand poses when i swap them out or is there a default skeleton with the animations ready to go that i use (if i need my own skeleton or animation i...

    How to swap oculus hand models with my own? (not a noob)
  • Vuforia 7 Model Targets. Hologram Drifting after Stopping Vuforia Behaviour I have tried the sample scene of Vuforia 7 Model Targets and deployed into HoloLens. The tracking works perfectly. It also works with the model that I wanted to track too. However, I wanted to close and stop the Vuforia Behaviour (meaning the camera ...
  • UWP App with Holographic Remoting Enabled cannot run as Standalone I followed this Unity Blog Post. It works good. Then I build my UWP app. I open it but Mixed Reality Portal comes up. I think, I am doing something wrong but I do not know what is the alternative. Can anybody tell me how to open an UWP app that Mixed ...