Forums

  • Unity Screen Space Canvas Sizing Incorrectly On ARCameras After updating Unity to 2018.3 and Vuforia to 8.0.10, Unity's Screen Space Canvas doesn't size properly on the AR Cameras. I've tested them on normal cameras and they size perfectly for them. What appears to be happening is that the height of the screen space canvas appears to be inverted from the actual height. Closer to camera is taller, further away is smaller.

    I've tried creating a new canvas after the scene is running, I've tried switching a canvas between the AR Camera and normal...

    Unity Screen Space Canvas Sizing Incorrectly On ARCameras
  • BUG: Tracked controllers don’t work when using LoadDeviceByName(“OpenVR”) More random regressions from the Unity Team. What else is new :(

    Tested in 2018.2.20.

    Problem 1: When trying to load SteamVR via LoadDeviceByName(), controller tracking never works.
    Problem 2: When setting "None" as primary device, and then loading OpenVR, console is spammed with

    Reproduce Problem 1:
    1. Install SteamVR plugin 1.2, drag CameraRig prefab into empty scene.
    2. Add "OpenVR" and "None" to VR SDK's, in that order.
    3. In frame 1, call XRSettings.LoadDeviceByName("None");
    4. In...

    BUG: Tracked controllers don't work when using LoadDeviceByName("OpenVR")
  • Looking for Ambitious Collaborators – Possible Job Opportunities Hello! I am a medical student in the United States. Myself and a couple of fellow students have come up with an idea we want to pursue incorporating VR into medical training. If there are any programmers/VR enthusiasts who would like to work with us...
  • Replacing the controller model with a custom model for the Mirage Solo (with Daydream) Hello, I am completely new to VR and Unity in general but looking at it for potential use in a research project, so am looking to see if some things are possible or not. My main concern are these: 1) I have a robotic arm (6 DOF) that I need to contro...
  • Can’t access to smartphone camera Hi everyone,

    I'm trying to build a very simple AR app. Actually, it's like the basic example: you point at a marker and a 3D model pops up. I've been this for ages, also with my old smartphone (Asus Zenfone 2). Now I'm trying with the One Plus 6, and when I run the app on the smartphone I can only see the Unity default "world". I've configured everything, since the app works with the webcam of my laptop.

    How can I resolve?

    I've attached the screenshot of what i get when I run the app on...

    Can't access to smartphone camera
  • Mobile Vr pipeline-problem with bake light! Hello i am having problem on baking light, deforms my textures i dont know why,..please help.
  • How to USE objets (with laser) in VRTK ? Hello,

    I'm new to using the VR Toolkit, and 'im currently struggling with how to trigger the InteractableObjectUsed event on an Interactable Object. I would like this object to be used (at a distance, using the laser pointer) on Trigger Press, and to be simply selected on Touchpad Press.

    Therefore, I've setup my right hand VRTK pointer this way :
    https://ibb.co/9GndczW

    And My VRTK_Interact_Use component (also on the same right hand controller) is...

    How to USE objets (with laser) in VRTK ?
  • HoloLens TCP Socket No Connection i have been trying for some days now to create a TCP connection from a HoloLens to my local machine. I know that there are many solutions out there, but i have no clue why i cannot connect to the device. Maybe anyone could help me or advise me what i a...
  • Measurements always off I must be either retarded or insane, trying to get proper measurements in the hololens it is always off by a little bit.

    Example:
    I have a table that is 15in. by 15in. I have 4 cubes that are parented to always be 15in apart. However, whenever I place the parent at exactly the corner, the other 4 cubes are slightly longer or shorter. The parent is anchored once it is placed so it shouldn't be moving.....
    Has anyone else ran into this issue with the hololens, this is driving me bonkers (I...

    Measurements always off
  • Can not connect Hololens in Remote – PerceptionRemotePlugin.dll not found Hello all,

    I tried for 3 days now to connect my Hololens and Unity but I try a lot of different versions and I always have the same error message :

    Failed to load PerceptionRemotePlugin.dll. The specified module could not be found.

    But the plugin is in the path specified...

    Thank's a lot for you help.

    Jimmy
  • Runtime created imageTargets recreated after load new scene. Hello,

    I have some trouble with understanding how work TrackerManager.Instance.GetStateManager().ReassociateTrackables();

    The description say's that removes destroyed trackables from lias and add newly created. I add this line to my DefaultTrackableEventHandler. From main scene, where I create some targets from runtime through DataSet.Load(). Then I load new scene with 1 predefined trackingImage, and also get all from previous scene. How I can prevent this?
  • Gamma Difference on Oculus Rift Headset – surfaces snap to black I'm working on a game on the Rift that takes place in low light. In the Editor, as I get the light intensity very low, I can get very near to black without getting all the way there. However, when viewing on the rift, everything is a little brighter (a lot actually) - like the gamma is brighter on the Rift or something.

    What this means is that when I try and get the light really low (like a dark blue moonlight (directional light)), as I approach smaller values - the surfaces lit by the...

    Gamma Difference on Oculus Rift Headset - surfaces snap to black
  • Camera show nothing Using Vuforia in Unity I Created an app in Unity using Vuforia AR.
    The camera seems blocked and I don't know why.
    I am currently using Unity 2018.3.0f2 and running on my PC. The application has included the Vuforia pack, and I have already created an Image target and an AR camera
    View attachment 356587
    It looks like this while playing
    Below is the Vuforia Configuration
    View attachment 356590
    and the player settings
    View attachment 356593

    Thank you so much!
  • GPU Skinning broken with OpenGLES3 Daydream (causes render artifacts) on 2018.3 I'm wondering if anyone has had similar issues and maybe found a workaround: We've upgraded our project to Unity 2018.3 and now have strange render artifacts and glitches, which look like this:

    View attachment 356521
    View attachment 356524
    Basically, all textures (including render textures) are garbled and flicker in wild colors as soon as a certain number of SkinnedMeshRenderers are present in the scene.

    This happens when:
    • SkinnedMeshRender count is above a certain number...

    GPU Skinning broken with OpenGLES3 Daydream (causes render artifacts) on 2018.3
  • Tensorflow in Unity Hi Other than the Matthew Hallberg video is there a more in depth guide to using Tensorflow for Object Detection in Unity? I need to see what is possible in simply detecting faces and specific logos. Please note that there is a HUGE difference in f...