Forums

  • Getting Odyssey HMD to work in Player while set to UWP build target I'm running Unity 2017.4.15f1 with Holotoolkit 2017.4.2.0 and when I try to run any scene including the toolkit examples the player does not get sent to my headset when I hit play. If i target PC Platform then it starts up Steam and does run in the player "somewhat "but the controllers don't work.

    I've double checked that I'm not running as admin as another post recommended but I'm 5 days in and still no luck. ANY help is appreciated.
  • Unity 5.6 VideoPlayer HLS Streaming Support Anyone know if the new Unity 5.6 VideoPlayer will have HLS support when it completes Beta? I've been using 5.6b1, and notice it can stream mp4s but not m3u8s. Is there perhaps another stream type I can use? Dash for instance?

    Thanks!
  • How to lock grabbed item to Knuckles? I am learning how to use the new interaction system provided in SteamVR 2.0. I now am a little familiar with actions and bindings. But I see that interactions only allow momentary grab (only grabbed while holding). How do I configure an interaction where the user makes a grab gesture to equip an object, but then the object sticks until "some other gesture" invokes the release of that object?

    What I don't under is the: "some other gesture" part. In other words, an ungrab gesture using...

    How to lock grabbed item to Knuckles?
  • ARCore vs AR Foundation I am a beginner with ARCore, confused because I also found this AR Foundation. https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@1.0/manual/index.html Do I need this or is ARCore (good) enough? Thanks! Freddy
  • [WMR] Unity keeps building for UWP in debug ??? I have a simple test project that I am trying to build for UWP, to display on a WMR headset on PC. The whole process is basically working, using the Build Window I can generate the project with IL2CPP backend and then build the appx version. I can also...
  • [Cardboard] Drag/Drop/Move objects with gaze pointer Hello Guys!!

    I've just started creating games in Unity3d for google cardboard so im kinda newbie

    I know how to make script which will move up/down/forward the object after target it with gaze pointer and click but i wonder how to make basic drag and drop script.
    I mean...

    target the object with your head (gaze pointer)
    click the button
    move the object in each direction using your head (up,down,left,right)
    drop the button = drop the object

    Thank you for every help! I wll really apreciate...

    Drag/Drop/Move objects with gaze pointer
  • [ Solved ] Hinge joint weird behavior Hello,

    I have a seat with a pivoting foot made with two primitives ( created with probuilder ) and connected by a hinge joint. The seat is gently turning on the foot axe, but when I collide anything on it or grab it, it start to get some really hard distortions.

    I really can't figure out what's happening here...

    here's a gif


    My chair is structured like so :
    • Prefab container
      • foot (having a convex mesh collider & the...

    Hinge joint weird behavior
  • Unable to place mid-air objects or use ground plane Hi all,

    I'm trying to place an object in mid-air and detect ground planes. When I follow the steps in the documentation, it doesn't work and I have the following error when debugging with adb:

    PositionalDeviceTracker has not been Initialized correctly, unable to create anchors

    I tried on an iPad running iOS 11.2, Pixel XL running Android 8.1.0 and a OnePlus 3T on Android 8.0.0 (which is not supporting ground planes but should work with mid-air anchors)
    I tried each on Unity 2017.3.0p4,...

    Unable to place mid-air objects or use ground plane
  • Speech input / voice recognition for HoloLens not updating on client with UNET- Unity Hey everyone,

    I'm trying to create a shared experience with UNET for the hololens in Unity. The good news is that dragging an object on the host hololens updates the position on the client however the colour of the cube does not update for the client with voice recognition, only the host, the holo player who creates the game session.

    The cube is supposed to change colour after the user shouts 'red.' The voice input works for the host but it doesn't update on the client. Why is this? What...

    Speech input / voice recognition for HoloLens not updating on client with UNET- Unity
  • Google VR 360 video error I'm Having an issue with the GVR Video player component where the video stops playing after approx 00:10s only on Google pixel mobile in all other devices it playing fine.

    I using

    Unity version: Unity 2018.3.0b10
    GVR SDK Version: GoogleVRForUnity_1.170.0
    Phone Model: Google Pixel 2 and 3
    Viewer: Daydream

    Please somebody help me
  • Wrong behaviour of camera as a child in gameobject Hi everybody, I have a task to rotate camera which located in gameobject. When camera rotation has x0 y0 z0 everything works perfect, but when I set i.e. z to 90 and trying to rotate my gameobject along Y axis, I have X rotation of camera instead, it n...
  • [ARCore] Black screen after upgrading I recently tried upgrading my project from ARCore 1.3 to 1.5. After doing so all I get is a black screen in a built app, my app no longer shows. If I try to use instant preview it shows for a second and then disappears acting like the instant previewer...
  • Converting IntPtr (ARCore camera YUV) to AndroidJavaObject https://forum.unity.com/threads/con...nel-to-androidjavaobject-without-copy.546633/

    It's almost same issue with the link.

    There is a comment asking to use NewDirectByteBuffer or Marshal.Copy, both of which require the length of YUV. I wonder if there is a way to get the length.
  • iPhoneX face camera meets Ableton over OSC I made this bridge utility for sending the face data over OSC if anyone is looking for a package in the future.
  • Editor crashes when opening project with updated OVR Integration version This has become quite a problem for me & I was wondering if anyone has any idea of how to fix it.

    Per the title, I foolishly updated the OVR plugin & now, my project will not open. Unity crashes EVERY TIME.
    I've tried deleting the ScriptAssemblies directory as suggested by someone on reddit's Unity sub.

    This worked, temporarily. I was able to work on my project. But now, I can't get it to open.

    If you've experienced this, how were you able to fix it?

    I've reported this problem,...

    Editor crashes when opening project with updated OVR Integration version